Xorp Blog Podcast

NO-IP.com: Élet a DYN.COM után

Aki használ Dynamic DNS szolgáltatást, az biztos ismeri a DYN.COM (régen DYNDNS.COM) weboldalt. Alapvetően a szolgáltatás a következőkből áll. Általában az otthoni internet elérésünkhöz dinamikus IP jár. Azaz valamennyi idő múlva új IP címet (és ezáltal új host nevet) fogunk kapni. Ez csak akkor lehet probléma, ha valamilyen szolgáltatást akarunk nyújtani az internetnek. Legjobb példa egy játék szerver. Hétvégente egyikünk csinál a saját gépéből egy szervert, és a többiek oda lépnek be. Egyszerűbb, ha a barátoknak ugyan azt az host nevet kell megadnunk, ami mindig ránk mutat. A Dinamikus DNS szolgáltatást abból áll, hogy kapunk egy egyedi host nevet a szolgáltatótól, a gépünkön, vagy a router-ünkön futnia kell a kliensnek, és a háttérből folyamatosan jelzi a szolgáltató számára, hogy milyen IP címünk van. Ha megváltozna, azonnal frissíti a szolgáltatónál a host nevünket, ezáltal ez a host név állandóan ránk fog mutatni.

DYN.COM pofátlansága

A DynDNS (DYN.com) az egyik legelső, és legnagyobb ilyen nyilvános szolgáltató volt. Néhány host név ingyenesen regisztrációval is működött. Évekig. Majd kitalálták, hogy érvénytelenné válik az szolgáltatás, ha minden hónapban egyszer nem lépünk be. Teljesen értelmetlen, de megtettem nekik. Majd most jött a hír, hogy TELJESEN megszüntetik az ingyenes szolgáltatásukat.

dyndns_end

Nem is ez a pofátlanság, mivel ez az ő szolgáltatásuk, ha tönkremennének, megint csak nem lenne, úgyhogy amit kell, azt tegyék meg. A pofátlanság az én részemről, hogy otthoni router-ek tömege támogatja csupán a DYN.com szolgáltatását. Tehát sok esetben működő, ingyenes szolgáltatás nem elérhető a router lehetőségei közül. Sajnos az én router-em is ide tartozik. Ez pedig pofátlanság. Bepromózni a szolgáltatást az elmúlt 10 évben a routerek közé, majd megszüntetni az ingyenességet. Na, de sebaj.

NO-IP.com

Keresnem sem kellett, hogy megtaláljam az alternatívát. NO-IP.com. A régi DYN.COM feltételei szerint tudjuk a igénybe venni a szolgáltatásukat. A router-em nem támogatja sajnos, ezért egy ubuntu csomagot installáltam egy hálózatban lévő gépre. Íme a lépések:

Először is töltsük le a csomagot, én előre elkészített ubuntu csomagot használtam, aki akarja fordíthatja magának.

# wget http://launchpadlibrarian.net/26258014/noip2_2.1.9-3_amd64.deb

Installáljuk a csomagot.

# dpkg -i noip2_2.1.9-3_amd64.deb

A telepítő a következő ablakokat fogja feldobni:

Adjuk meg a felhasználó nevünket, majd a következő ablakban a jelszavunkat.

noip1

Adjuk meg, hogy milyen sűrűn frissítse az IP-nket a helyi program.

noip2

Megadhatjuk, hogy milyen host nevet frissítsen. Ha csak egyet használunk, akkor üresen hagyhatjuk.

noip3

Adjuk meg, hogy melyik hálózati interface-t használja a program.

noip4

Ha akarjuk, kikapcsolhatjuk, hogy kívülről legyen meghatározva az IP címünk. Ez szükséges akkor, ha router mögött vagyunk. Tehát legtöbb esetben, ne akarjuk kikapcsolni.

noip5

Majd a csomag települ, és a helyi service elindul, és már frissíti is az IP-nket.

noip6

Ennyi.

Categories: Informatika, Linux/Unix

iFlicks 2 – Filmek rendezése » « Knights and Merchants

1 Comment

  1. No-IP.com update script Mikrotik router tulajoknak. Ezt /system/scripts-be betenni, majd /scheduler-ből futtatni mondjuk félóránként. (előtte én is dyndns-t használtam, és én is belefutottam a fentírtakba)

    # No-IP automatic Dynamic DNS update

    #————— Change Values in this section to match your setup ——————

    # No-IP User account info
    :local noipuser “no-ip-com-username”
    :local noippass “no-ip-com-jelszó”

    # Set the hostname or label of network to be updated.
    # Hostnames with spaces are unsupported. Replace the value in the quotations below with your host names.
    # To specify multiple hosts, separate them with commas.
    :local noiphost “no-ip-com-hostname”

    # Change to the name of interface that gets the dynamic IP address
    :local inetinterface “VDSL2″

    #————————————————————————————
    # No more changes need

    :global previousIP

    :if ([/interface get $inetinterface value-name=running]) do={
    # Get the current IP on the interface
    :local currentIP [/ip address get [find interface=”$inetinterface” disabled=no] address]

    # Strip the net mask off the IP address
    :for i from=( [:len $currentIP] – 1) to=0 do={
    :if ( [:pick $currentIP $i] = “/”) do={
    :set currentIP [:pick $currentIP 0 $i]
    }
    }

    :if ($currentIP != $previousIP) do={
    :log info “No-IP: Current IP $currentIP is not equal to previous IP, update needed”
    :set previousIP $currentIP

    # The update URL. Note the “\3F” is hex for question mark (?). Required since ? is a special character in commands.
    :local url “http://dynupdate.no-ip.com/nic/update\3Fmyip=$currentIP”
    :local noiphostarray
    :set noiphostarray [:toarray $noiphost]
    :foreach host in=$noiphostarray do={
    :log info “No-IP: Sending update for $host”
    /tool fetch url=($url . “&hostname=$host”) user=$noipuser password=$noippass mode=http dst-path=(“no-ip_ddns_update-” . $host . “.txt”)
    :log info “No-IP: Host $host updated on No-IP with IP $currentIP”
    }
    } else={
    :log info “No-IP: Previous IP $previousIP is equal to current IP, no update needed”
    }
    } else={
    :log info “No-IP: $inetinterface is not currently running, so therefore will not update.”
    }

Hozzászólás

Copyright © 2018 Xorp Blog Podcast

Theme by Anders NorenUp ↑

%d blogger ezt szereti: